FIXED – An attempt has been made to use a data extension ‘ADS’ … with Access Services 2010
The below error might appear if you are using Access Services 2010 for the first time. The local Access 2010 publishing wizard will create RDL and RSDS files for reports you have. However, the SSRS server side configuration may require a minor update to enable ADS (Access Data Server). See http://technet.microsoft.com/en-us/library/ee662542.aspx for full details.
The instructions are pretty clear except for where to find the “rssrvpolicy.config” file. Mine was under C:Program FilesMicrosoft SQL ServerMSRS10_50.MSSQLSERVERReporting ServicesReportServer. Hope that helps. If you’d like to learn Access Service 2010 on your system be sure to check out the Northwind 2010 Web Database at http://office.microsoft.com/en-us/templates/results.aspx?qu=northwind&ex=1 ![]()
Successful Report
Error Detail
- An error has occurred during report processing. (rsProcessingAborted)
An attempt has been made to use a data extension ‘ADS’ that is either not registered for this report server or is not supported in this edition of Reporting Services. (rsDataExtensionNotFound) - An error has occurred during report processing. (rsProcessingAborted)
The Group expression for the grouping ‘Group1’ contains an error: Request for the permission of type ‘Microsoft.Office.Access.Server.Security.AccessServicesPermission, Microsoft.Office.Access.Server.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c’ failed. (rsRuntimeErrorInExpression)


after editing the script “rssrvpolicy.config”, now i get message on the web page:
“The action or method requires an argument: ObjecName”
Hello SPJeff, I am receiving the second error in the Contacts web database, the difference is that we are running SQL Server 2012 sp1 with SP2010 sp1. Do you have any solution to fix this on SQL2012 as it does not use the “rssrvpolicy.config” file.
Hi Dave,
I haven’t seen this error come up with SQL2012. My understanding is that the SSRS model changed to a full Service Application with 2012 so it would make sense the configuration has moved. Best of luck with troubleshooting, sorry this post didn’t match up with the newer config.